Calculation aborted on Linux machine

I run Q-Chem calculations on Ubuntu 22.04 LTS (dual boot with Windows). When I run relatively costly calculation, the following message appears in a teminal and the calculation is aborted.

terminate called after throwing an instance of ‘libvmm::io_exception’
what(): libvmm::page_file_posix::write(const pos_t&, size_t, const element_t*), /scratch/qcdevops/jenkins/workspace/build_qchem_linux_distrib/tags/qc522/qchem/libvmm/libvmm/page_file_posix.C (237), io_exception
pwrite (No space left on device)
/opt/qchem/5.2/bin/qchem: line 126: 460559 Aborted (core dumped) ${QCPROG_S} ${inp} ${scr}

There is “No space left on device” message, but there is 40 GB of free space available.
What can be the cause of this error?

Well, I guess that the job needs more than 40GB. So, you might have 40GB left at the beginning and/or the end. But in between Q-Chem wants to write scratch files that are bigger.

The only solution, really, is to run this on a system with a larger disk.


1 Like

Thank you for your reply. I confirmed that the scratch directory filled up during calculation. As you say, I simply need more disk space. I appreciate your help.