Missing output files with transmission calculation

Hi all,

I’m new to Q-Chem with only a bit of Gaussian experience before that. I tried myself at the molecular junction test input file (in C:\QChem\5.3.1\samples\ecp\tchem-c6.in) for version 5.3.1.
I can’t figure out how to get the wanted output files such as

• transmission.txt (Transmission function in the requested energy window)
• TDOS.txt (Total density of states)
• current.txt (I-V plot only for the Landauer level)

despite the active print command (at least for the latter two)

Can anyone verify or dispute this?

Thank you very much already!

I do not know much about this code at all, but when I run the sample job called tchem-c6.in (pasted below for reference), in addition to the usual Q-Chem output file I get the following: Smat.dat, DAmat.dat, FAmat.dat, TDOS.txt, and transmission.txt. I do NOT get current.txt.

I think some cleanup of that part of the manual is underway.

0 1
Ag -11.0 0 0
Au -8.3 0 0
Ag -5.6 0 0
Au -2.9 0 0
Ag -0.2 0 0
Au 2.5 0 0
C 4.8 0 0
C 6.5 0 0
C 8.2 0 0
C 9.9 0 0
C 11.6 0 0
C 13.3 0 0
Au 15.6 0 0
Ag 18.3 0 0
Au 21.0 0 0
Ag 23.7 0 0
Au 26.4 0 0
Ag 29.1 0 0

jobtype SP
exchange B3LYP
correlation none
BASIS lanl2dz
ECP fit-lanl2dz
mem_static 400
max_scf_cycles 400
scf_convergence 10
scf_algorithm diis
trans_enable 1

trans_spin 0
trans_npoints 300
trans_method 0
trans_readhs 0
trans_printdos 1
trans_efermi -6.50
trans_vmax 4.00

trans_lgatom 3
trans_latom 5
trans_ratom 14
trans_rgatom 16

Hi jherbert,

Thank you I will try it with this input file right away. It seems to differ slightly from the example I have in my version of Q-Chem.

Did you execute it in the main q-chem directory?
Also did you specify anything out of the ordinary in the shell command?


Just tried it.

It the additional .txt-files are not generated. Neither in the directory in which I run the calculation nor in the scratch directory.

I use the windows version of q-chem btw.

Mine was run under linux. I did nothing special except take the input file that was given and do something like:
qchem -nt 7 tchem-c6.in tchem-c6.out

I copied it from samples directory into a scratch directory, but shouldn’t matter so long as you’re putting it somewhere that you have read/write permission. I also just confirmed that it works for me also on a single processor (omitting “-nt 7” above).

It is possible there is a windows-specific bug that is beyond my abilities to diagnose (or even test). I think you should contact Q-Chem support with this issue:

Hi John,

Thank you for validating this as best as possible.
Quite possible that Windows for whatever reason prohibits Q-Chem from writing these files.

I will ask the support.