NMR calculation crashes with finer basis set


I am trying to run an NMR calculation (job type is ISSC) for a molecule using the cc-PV5Z basis set and B3LYP exchange. The complete input file is:

0 1
Ca  1 3.408
Ca  1 3.397  2  60.008
P   3 2.946  1  54.819  2 294.1
O   4 1.498  3 138.358  1 217.5
O   4 1.637  3  50.386  1 305.8
O   4 1.637  3  50.165  1 129.5
O   4 1.637  3 104.129  1  37.8
P   3 2.946  1  54.819  2  65.9
O   9 1.498  3 138.358  1 142.5
O   9 1.637  3  50.386  1  54.2
O   9 1.637  3  50.165  1 230.5
O   9 1.637  3 104.129  1 322.2

   JOBTYPE          ISSC
   EXCHANGE         B3LYP
   BASIS            cc-PV5Z
   MEM_STATIC       1000

However, my job always crashes with the following error:

Q-Chem fatal error occurred in module 0, line  349:

 No paths available in SetAllIntsDrivers!

 Q-Chem fatal error occurred in module forms2/ShlPairs.C, line 54:

 In ~ShlPairs:  s2Ints != 0.

I am running it on 36 cores and 36 threads, all on the same node (in case that makes a difference for the error). Could someone please tell me what this error pertains to and how to get around it? The same calculation with a 6-311G(dip) basis sets runs successfully.


The error message is a bit cryptic but I think this is Q-Chem complaining about not having the right integrals implemented, presumably due to the high angular momentum functions in cc-pV5Z (up to H functions for this molecule). I am able to run the same job cc-pVQZ. Here’s a simplified input that will exhibit the crash for 5Z, or not crash for QZ:

0 1
O 1 1.5

method hf
mem_total 1000
print_general_basis true

Thanks for that explanation. That helps! Even I was able to run it with QZ and was not sure whether the error for 5Z could be solved by adding some other parameters. I’ll stick to QZ then.


I was trying something else and noticed that I get the same error when I perform NMR ISSC calculation on my system with a pcJ-4 basis set. Now, given that the pcJ-4 basis set was exclusively built for the calculation of NMR coupling constants, it feels weird that there are not enough integrals implemented within QChem to perform this type of calculation with the pcJ-4 basis set. Could you kindly give your thoughts on this?


It’s not weird, I’m suggesting that it’s probably a limit on angular momentum integrals. For 2nd-row atoms (e.g., oxygen), pcJ-4 has H functions just like cc-pV5Z in your earlier question. You can test by hypothesis by implementing pcJ-4 using a general basis format (BASIS=GEN in $rem and a $basis input section) and systematically eliminating angular momentum classes, starting with the highest one (H functions).

Update: I did the experiment myself, and pcJ-4 sans H-functions does in fact run to completion for O2 molecule, whereas standard pcJ-4 fails with the aforementioned error.