I am currently testing the QCHEM QM/MM feature in CHARMM. I have a simulation that works well with the standard QM/MM module in CHARMM, but when I run the same thing with QCHEM, the QM region just disintegrates. My QCHEM inputs are:


My QCHEM.inp file (in the environment variable) is:

Input file comes from CHARMM

exchange HF
basis 3-21G
qm_mm true
jobtype force
symmetry off
sym_ignore true
print_input false
qmmm_print true

-2 1

I cannot figure out why this would go wrong.

(a) This is impossible to diagnose without your full input
(b) If you are using CHARMM already, why not use the Q-Chem/CHARMM interface?


  1. I realized that but was hoping that I just made a silly fundamental error in the inputs.
  2. I am using the Q-Chem/CHARMM interface which I switched over from the standard CHARMM/QMMM module. I am trying to figure out if there was any incompatibility that are not documented.

As far as the syntax of the Q-Chem input is concerned I do not see any problems here.

Will it work if you try a very simple system, say H2O dimer with one molecule as QM the other as MM for just one MD time step or one optimization step? Are you able to post CHARMM and Q-Chem outputs for this small test?

Sorry for the delay in replying to this question, but I think your problem is down to using the “COOR” keyword. This definitely will cause problem when using only “jobtype force”. Here is the CHARMM documentation about that keyword…

COORdinates: This keyword will activate CHARMM to obtain an updated geometry
from Q-Chem as the calculation proceeds. This can be particularly
useful as Q-Chem can perform QM optimiztions using delocalized
internal coordinates in the presence of a fix field of point charges.
This can significantly speed QM/MM minimizations and can be used in
an iterative approach. Note: to use this the JOBTYPE in the Q-Chem
control file should be set to OPT (i.e. JOBTYPE = OPT).

Please try removing this keyword and seeing you still get the same problem.