Unanswered iQmol / Q-Chem question on Matter Modeling Stack Exchange

Greetings to all!

A user of ours asked this question on the Matter Modeling Stack Exchange, about using iQmol as a tool to submit Q-Chem calculations to make it easier for his organic chemistry students. Several people tried to help him, but with no success.

He said that he contacted Q-Chem support and was told to re-direct this to the iQmol team, but the iQmol website and manual don’t seem to say anything about how to ask questions about iQmol, but I do see some iQmol questions here on talk.q-chem.

The user’s question seems to pre-date the existence of talk.q-chem by about 2 months, so I can see why it wasn’t asked here, but now we’d like to have the question answered since it’s one of the oldest questions in our unanswered queue!

Once again the question is here: https://mattermodeling.stackexchange.com/q/879/5.

With my very best wishes!

This looks like the job is simply timing out. (DFT frequencies more time-consuming than the HF single point that worked.) Suggests to me that the user is probably actually submitting to the server that Q-Chem owns, which is the default option in IQmol. Those jobs are time-limited at about 10 min. For longer jobs, this person would need a Q-Chem license and would need to set up IQmol to submit jobs to the local machine, which certainly can be done.

I am unable to reproduce the problem and the only thing that I can think of at the moment is that the limits (e.g. stack size) are somehow different when running under a QProcess (a Qt class that IQmol uses to run external processes, i.e. Q-Chem). If the DFT second derivative code made heavy use of the stack, then this could trigger a stack problem that only occurs under the QProcess. You could try adding the following line to the IQmol server configuration just before the qchem command to check these limits:

limit > limit.txt

When successfully running the job from the command line, is the calculation being run in parallel?

Thanks @andrew !!
I don’t know the user that asked that question, I was just bringing it to the attention of this forum since the user had been struggling with the problem for almost 1 year. I looked at the users of this forum and don’t see his name here, so perhaps he’s not using it, which isn’t impossible since he asked the question 2 months before this forum first went live.

He is quite active over there though, so if you ask him about if it’s being run in parallel, he is likely to respond quickly!